What’s Vulnerable › Vulnerabilities
CVE-2020-7060: global buffer-overflow in mbfl_filt_conv_big5_wchar
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-10 · updated 2026-06-17
- Weakness: CWE-125
Description
When using certain mbstring functions to convert multibyte encodings, in PHP versions 7.2.x below 7.2.27, 7.3.x below 7.3.14 and 7.4.x below 7.4.2 it is possible to supply data that will cause function mbfl_filt_conv_big5_wchar to read past the allocated buffer. This may lead to information disclosure or crash.
Affected products
- Debian Linux: 8.0
- openSUSE Leap: 15.1
- Oracle Corporation Communications Diameter Signaling Router (DSR): from 8.0 through 8.4
- PHP: from 7.2.0 before 7.2.27; from 7.3.0 before 7.3.14; from 7.4.0 before 7.4.2 — fixed in 7.2.27, 7.3.14, 7.4.2
- Tenable.sc: before 5.19.0 — fixed in 5.19.0
How to fix
Upgrade to a fixed version: PHP 7.2.27, 7.3.14, 7.4.2; Tenable.sc 5.19.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00023.html
- https://bugs.php.net/bug.php?id=79037
- https://lists.debian.org/debian-lts-announce/2020/02/msg00030.html
- https://seclists.org/bugtraq/2020/Feb/27
- https://seclists.org/bugtraq/2020/Feb/31
- https://seclists.org/bugtraq/2021/Jan/3
- https://security.gentoo.org/glsa/202003-57
- https://security.netapp.com/advisory/ntap-20200221-0002/
- https://usn.ubuntu.com/4279-1/
- https://www.debian.org/security/2020/dsa-4626
- https://www.debian.org/security/2020/dsa-4628
- https://www.oracle.com/security-alerts/cpuApr2021.html
Get alerted when CVE-2020-7060 or the next vulnerability affects your stack