What’s Vulnerable › Vulnerabilities
CVE-2020-7065: mb_strtolower (UTF-32LE): stack-buffer-overflow at php_unicode_tolower_full
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-01 · updated 2026-06-17
- Weakness: CWE-121
Description
In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.10, 20.04
- Debian Linux: 10.0
- PHP: from 7.3.0 before 7.3.16; from 7.4.0 before 7.4.4 — fixed in 7.3.16, 7.4.4
- Tenable.sc: before 5.19.0 — fixed in 5.19.0
How to fix
Upgrade to a fixed version: PHP 7.3.16, 7.4.4; Tenable.sc 5.19.0. Check the vendor advisory for mitigations.
References
- https://bugs.php.net/bug.php?id=79371
- https://security.netapp.com/advisory/ntap-20200403-0001/
- https://usn.ubuntu.com/4330-1/
- https://usn.ubuntu.com/4330-2/
- https://www.debian.org/security/2020/dsa-4719
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.php.net/ChangeLog-7.php#7.4.4
- https://www.tenable.com/security/tns-2021-14
- https://bugs.php.net/bug.php?id=79371
- https://security.netapp.com/advisory/ntap-20200403-0001/
- https://usn.ubuntu.com/4330-1/
- https://usn.ubuntu.com/4330-2/
Get alerted when CVE-2020-7065 or the next vulnerability affects your stack