What’s Vulnerable › Vulnerabilities

CVE-2020-7067: OOB Read in urldecode()

Description

In PHP versions 7.2.x below 7.2.30, 7.3.x below 7.3.17 and 7.4.x below 7.4.5, if PHP is compiled with EBCDIC support (uncommon), urldecode() function can be made to access locations past the allocated memory, due to erroneously using signed numbers as array indexes.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.2.30, 7.3.17, 7.4.5; Tenable.sc 5.19.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-7067 or the next vulnerability affects your stack