What’s Vulnerable › Vulnerabilities
CVE-2020-7071: FILTER_VALIDATE_URL accepts URLs with invalid userinfo
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-15 · updated 2026-06-17
- Weakness: CWE-20
Description
In PHP versions 7.3.x below 7.3.26, 7.4.x below 7.4.14 and 8.0.0, when validating URL with functions like filter_var($url, FILTER_VALIDATE_URL), PHP will accept an URL with invalid password as valid URL. This may lead to functions that rely on URL being valid to mis-parse the URL and produce wrong data as components of the URL.
Affected products
- Debian Linux: 9.0, 10.0
- Clustered Data ONTAP: all versions
- PHP: from 7.3.0 before 7.3.26; from 7.4.0 before 7.4.14; from 8.0.0 before 8.0.1 — fixed in 7.3.26, 7.4.14, 8.0.1
How to fix
Upgrade to a fixed version: PHP 7.3.26, 7.4.14, 8.0.1. Check the vendor advisory for mitigations.
References
- https://bugs.php.net/bug.php?id=77423
- https://lists.debian.org/debian-lts-announce/2021/07/msg00008.html
- https://security.gentoo.org/glsa/202105-23
- https://security.netapp.com/advisory/ntap-20210312-0005/
- https://www.debian.org/security/2021/dsa-4856
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.tenable.com/security/tns-2021-14
- https://bugs.php.net/bug.php?id=77423
- https://lists.debian.org/debian-lts-announce/2021/07/msg00008.html
- https://security.gentoo.org/glsa/202105-23
- https://security.netapp.com/advisory/ntap-20210312-0005/
- https://www.debian.org/security/2021/dsa-4856
Get alerted when CVE-2020-7071 or the next vulnerability affects your stack