What’s Vulnerable › Vulnerabilities
CVE-2020-7106
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Cacti 1.2.8 has stored XSS in data_sources.php, color_templates_item.php, graphs.php, graph_items.php, lib/api_automation.php, user_admin.php, and user_group_admin.php, as demonstrated by the description parameter in data_sources.php (a raw string from the database that is displayed by $header to trigger the XSS).
Affected products
- cacti: before 1.2.9 — fixed in 1.2.9
- Debian Linux: 8.0, 9.0
- Fedoraproject Extra Packages For Enterprise Linux: 7.0, 8.0, 9.0
- Fedoraproject Fedora: 30, 31
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
- SUSE Package Hub: all versions
How to fix
Upgrade to a fixed version: cacti 1.2.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00048.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00032.html
- https://github.com/Cacti/cacti/issues/3191
- https://lists.debian.org/debian-lts-announce/2020/01/msg00014.html
- https://lists.debian.org/debian-lts-announce/2022/03/msg00038.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SUSOTOIEJKD2IWJHN7TY56TDZJQZJUVJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XLZAMGTW2OSIBLYLXWHQBGWP7M4DTRS7/
- https://security.gentoo.org/glsa/202003-40
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00001.html
Get alerted when CVE-2020-7106 or the next vulnerability affects your stack