What’s Vulnerable › Vulnerabilities
CVE-2020-7108
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The LearnDash LMS plugin before 3.1.2 for WordPress allows XSS via the ld-profile search field.
Affected products
- StellarWP LearnDash LMS: from 3.0 before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: StellarWP LearnDash LMS 3.1.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/156275/LearnDash-WordPress-LMS-3.1.2-Cross-Site-Scripting.html
- https://learndash.releasenotes.io/release/uCskc-version-312
- https://wpvulndb.com/vulnerabilities/10026
- https://www.getastra.com/blog/911/plugin-exploit/reflected-xss-vulnerability-found-in-learndash-lms-plugin/
- https://www.jinsonvarghese.com/reflected-xss-in-learndash-wordpress-plugin/
- http://packetstormsecurity.com/files/156275/LearnDash-WordPress-LMS-3.1.2-Cross-Site-Scripting.html
- https://learndash.releasenotes.io/release/uCskc-version-312
- https://wpvulndb.com/vulnerabilities/10026
- https://www.getastra.com/blog/911/plugin-exploit/reflected-xss-vulnerability-found-in-learndash-lms-plugin/
- https://www.jinsonvarghese.com/reflected-xss-in-learndash-wordpress-plugin/
Get alerted when CVE-2020-7108 or the next vulnerability affects your stack