What’s Vulnerable › Vulnerabilities
CVE-2020-7218
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-31 · updated 2026-06-17
- Weakness: CWE-770
Description
HashiCorp Nomad and Nonad Enterprise up to 0.10.2 HTTP/RPC services allowed unbounded resource usage, and were susceptible to unauthenticated denial of service. Fixed in 0.10.3.
Affected products
- HashiCorp Nomad Enterprise: before 0.10.3 — fixed in 0.10.3
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 0.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/hashicorp/nomad/issues/7002
- https://www.hashicorp.com/blog/category/nomad/
- https://github.com/hashicorp/nomad/issues/7002
- https://www.hashicorp.com/blog/category/nomad/
Get alerted when CVE-2020-7218 or the next vulnerability affects your stack