What’s Vulnerable › Vulnerabilities
CVE-2020-7239
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The conversation-watson plugin before 0.8.21 for WordPress has a DOM-based XSS vulnerability that is executed when a chat message containing JavaScript is sent.
Affected products
- IBM Chatbot With Ibm Watson: before 0.8.21 — fixed in 0.8.21
How to fix
Upgrade to a fixed version: IBM Chatbot With Ibm Watson 0.8.21. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/conversation-watson/#developers
- https://wpvulndb.com/vulnerabilities/10035
- https://www.hooperlabs.xyz/disclosures/cve-2020-7239.php
- https://wordpress.org/plugins/conversation-watson/#developers
- https://wpvulndb.com/vulnerabilities/10035
- https://www.hooperlabs.xyz/disclosures/cve-2020-7239.php
Get alerted when CVE-2020-7239 or the next vulnerability affects your stack