What’s Vulnerable › Vulnerabilities
CVE-2020-7350: Metasploit Framework Plugin Libnotify Command Injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Rapid7 Metasploit Framework versions before 5.0.85 suffers from an instance of CWE-78: OS Command Injection, wherein the libnotify plugin accepts untrusted user-supplied data via a remote computer's hostname or service name. An attacker can create a specially-crafted hostname or service name to be imported by Metasploit from a variety of sources and trigger a command injection on the operator's terminal. Note, only the Metasploit Framework and products that expose the plugin system is susceptible to this issue -- notably, this does not include Rapid7 Metasploit Pro. Also note, this vulnerability cannot be triggered through a normal scan operation -- the attacker would have to supply a file that is processed with the db_import command.
Affected products
- Rapid7 Metasploit Framework: before 5.0.85 — fixed in 5.0.85
How to fix
Upgrade to a fixed version: Rapid7 Metasploit Framework 5.0.85. Check the vendor advisory for mitigations.
References
- https://github.com/rapid7/metasploit-framework/issues/13026
- https://github.com/rapid7/metasploit-framework/issues/13026
Get alerted when CVE-2020-7350 or the next vulnerability affects your stack