What’s Vulnerable › Vulnerabilities
CVE-2020-7385: Metasploit Framework 'drb_remote_codeexec' code execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-23 · updated 2026-06-17
- Weakness: CWE-502
Description
By launching the drb_remote_codeexec exploit, a Metasploit Framework user will inadvertently expose Metasploit to the same deserialization issue that is exploited by that module, due to the reliance on the vulnerable Distributed Ruby class functions. Since Metasploit Framework typically runs with elevated privileges, this can lead to a system compromise on the Metasploit workstation. Note that an attacker would have to lie in wait and entice the Metasploit user to run the affected module against a malicious endpoint in a "hack-back" type of attack. Metasploit is only vulnerable when the drb_remote_codeexec module is running. In most cases, this cannot happen automatically.
Affected products
- Rapid7 Metasploit Framework: before 4.19.0 — fixed in 4.19.0
How to fix
Upgrade to a fixed version: Rapid7 Metasploit Framework 4.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/rapid7/metasploit-framework/pull/14300
- https://github.com/rapid7/metasploit-framework/pull/14335
- https://help.rapid7.com/metasploit/release-notes/archive/2020/10/
- https://github.com/rapid7/metasploit-framework/pull/14300
- https://github.com/rapid7/metasploit-framework/pull/14335
- https://help.rapid7.com/metasploit/release-notes/archive/2020/10/
Get alerted when CVE-2020-7385 or the next vulnerability affects your stack