What’s Vulnerable › Vulnerabilities
CVE-2020-7465
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-06 · updated 2026-06-17
- Weakness: CWE-787
Description
The L2TP implementation of MPD before 5.9 allows a remote attacker who can send specifically crafted L2TP control packet with AVP Q.931 Cause Code to execute arbitrary code or cause a denial of service (memory corruption).
Affected products
- Mpd Project Mpd: before 5.9 — fixed in 5.9
- Stormshield Network Security: from 4.0.0 before 4.3.17; 4.4.0 — fixed in 4.3.17
How to fix
Upgrade to a fixed version: Mpd Project Mpd 5.9; Stormshield Network Security 4.3.17. Check the vendor advisory for mitigations.
References
- https://sourceforge.net/p/mpd/bugs/70/
- https://sourceforge.net/p/mpd/svn/2377/
- https://sourceforge.net/p/mpd/bugs/70/
- https://sourceforge.net/p/mpd/svn/2377/
Get alerted when CVE-2020-7465 or the next vulnerability affects your stack