What’s Vulnerable › Vulnerabilities
CVE-2020-7466
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-06 · updated 2026-06-17
- Weakness: CWE-125
Description
The PPP implementation of MPD before 5.9 allows a remote attacker who can send specifically crafted PPP authentication message to cause the daemon to read beyond allocated memory buffer, which would result in a denial of service condition.
Affected products
- Mpd Project Mpd: before 5.9 — fixed in 5.9
- Stormshield Network Security: from 4.0.0 before 4.3.17; 4.4.0 — fixed in 4.3.17
How to fix
Upgrade to a fixed version: Mpd Project Mpd 5.9; Stormshield Network Security 4.3.17. Check the vendor advisory for mitigations.
References
- https://sourceforge.net/p/mpd/bugs/69/
- https://sourceforge.net/p/mpd/svn/2374/
- https://sourceforge.net/p/mpd/bugs/69/
- https://sourceforge.net/p/mpd/svn/2374/
Get alerted when CVE-2020-7466 or the next vulnerability affects your stack