What’s Vulnerable › Vulnerabilities
CVE-2020-7596
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-25 · updated 2026-06-17
- Weakness: CWE-78
Description
Codecov npm module before 3.6.2 allows remote attackers to execute arbitrary commands via the "gcov-args" argument.
Affected products
- codecov Nodejs Uploader: before 3.6.2 — fixed in 3.6.2
How to fix
Upgrade to a fixed version: codecov Nodejs Uploader 3.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-7596 or the next vulnerability affects your stack