What’s Vulnerable › Vulnerabilities
CVE-2020-7597
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-02-17 · updated 2026-06-17
- Weakness: CWE-78
Description
codecov-node npm module before 3.6.5 allows remote attackers to execute arbitrary commands.The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js. This vulnerability exists due to an incomplete fix of CVE-2020-7596.
Affected products
- codecov npm module: before 3.6.5 — fixed in 3.6.5
How to fix
Upgrade to a fixed version: codecov npm module 3.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/codecov/codecov-node/commit/02cf13d8b93ac547b5b4c2cfe186b7d874fd234f
- https://snyk.io/vuln/SNYK-JS-CODECOV-548879
- https://github.com/codecov/codecov-node/commit/02cf13d8b93ac547b5b4c2cfe186b7d874fd234f
- https://snyk.io/vuln/SNYK-JS-CODECOV-548879
Get alerted when CVE-2020-7597 or the next vulnerability affects your stack