What’s Vulnerable › Vulnerabilities
CVE-2020-7609
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-27 · updated 2026-06-17
- Weakness: CWE-94
Description
node-rules including 3.0.0 and prior to 5.0.0 allows injection of arbitrary commands. The argument rules of function "fromJSON()" can be controlled by users without any sanitization.
Affected products
- node-rules: from 3.0.0 before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: node-rules 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/mithunsatheesh/node-rules/commit/100862223904bb6478fcc33b701c7dee11f7b832%2C
- https://snyk.io/vuln/SNYK-JS-NODERULES-560426
- https://github.com/mithunsatheesh/node-rules/commit/100862223904bb6478fcc33b701c7dee11f7b832
- https://github.com/mithunsatheesh/node-rules/commit/100862223904bb6478fcc33b701c7dee11f7b832%2C
- https://snyk.io/vuln/SNYK-JS-NODERULES-560426
Get alerted when CVE-2020-7609 or the next vulnerability affects your stack