What’s Vulnerable › Vulnerabilities
CVE-2020-7611
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-30 · updated 2026-06-17
- Weakness: CWE-444
Description
All versions of io.micronaut:micronaut-http-client before 1.2.11 and all versions from 1.3.0 before 1.3.2 are vulnerable to HTTP Request Header Injection due to not validating request headers passed to the client.
Affected products
- micronaut-projects micronaut-core: before 1.2.11; from 1.3.0 before 1.3.2 — fixed in 1.2.11, 1.3.2
How to fix
Upgrade to a fixed version: micronaut-projects micronaut-core 1.2.11, 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/micronaut-projects/micronaut-core/commit/9d1eff5c8df1d6cda1fe00ef046729b2a6abe7f1
- https://github.com/micronaut-projects/micronaut-core/security/advisories/GHSA-694p-xrhg-x3wm
- https://snyk.io/vuln/SNYK-JAVA-IOMICRONAUT-561342
- https://github.com/micronaut-projects/micronaut-core/commit/9d1eff5c8df1d6cda1fe00ef046729b2a6abe7f1
- https://github.com/micronaut-projects/micronaut-core/security/advisories/GHSA-694p-xrhg-x3wm
- https://snyk.io/vuln/SNYK-JAVA-IOMICRONAUT-561342
Get alerted when CVE-2020-7611 or the next vulnerability affects your stack