What’s Vulnerable › Vulnerabilities
CVE-2020-7658
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-22 · updated 2026-06-17
- Weakness: CWE-444
Description
meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.
Affected products
- meinheld: before 1.0.2 — fixed in 1.0.2
How to fix
Upgrade to a fixed version: meinheld 1.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/mopemope/meinheld/blob/master/CHANGES.rst%2C
- https://snyk.io/vuln/SNYK-PYTHON-MEINHELD-569140
- https://github.com/mopemope/meinheld/blob/master/CHANGES.rst%2C
- https://snyk.io/vuln/SNYK-PYTHON-MEINHELD-569140
Get alerted when CVE-2020-7658 or the next vulnerability affects your stack