What’s Vulnerable › Vulnerabilities
CVE-2020-7660: Insecure serialization leading to RCE in serialize-javascript
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-01 · updated 2026-06-17
- Weakness: CWE-502
Description
serialize-javascript prior to 3.1.0 allows remote attackers to inject arbitrary code via the function "deleteFunctions" within "index.js".
Affected products
- serialize-javascript: before 3.1.0 — fixed in 3.1.0
- Npm Serialize-Javascript: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: serialize-javascript 3.1.0; Npm Serialize-Javascript 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/yahoo/serialize-javascript/commit/f21a6fb3ace2353413761e79717b2d210ba6ccbd
- https://github.com/yahoo/serialize-javascript/commit/f21a6fb3ace2353413761e79717b2d210ba6ccbd
Get alerted when CVE-2020-7660 or the next vulnerability affects your stack