What’s Vulnerable › Vulnerabilities
CVE-2020-7680
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-20 · updated 2026-06-17
- Weakness: CWE-79
Description
docsify prior to 4.11.4 is susceptible to Cross-site Scripting (XSS). Docsify.js uses fragment identifiers (parameters after # sign) to load resources from server-side .md files. Due to lack of validation here, it is possible to provide external URLs after the /#/ (domain.com/#//attacker.com) and render arbitrary JavaScript/HTML inside docsify page.
Affected products
- docsify: before 4.11.4 — fixed in 4.11.4
How to fix
Upgrade to a fixed version: docsify 4.11.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/158515/Docsify.js-4.11.4-Cross-Site-Scripting.html
- http://packetstormsecurity.com/files/161495/docsify-4.11.6-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2021/Feb/71
- https://github.com/docsifyjs/docsify/issues/1126
- https://github.com/docsifyjs/docsify/pull/1128
- https://snyk.io/vuln/SNYK-JS-DOCSIFY-567099
- http://packetstormsecurity.com/files/158515/Docsify.js-4.11.4-Cross-Site-Scripting.html
- http://packetstormsecurity.com/files/161495/docsify-4.11.6-Cross-Site-Scripting.html
- http://seclists.org/fulldisclosure/2021/Feb/71
- https://github.com/docsifyjs/docsify/issues/1126
- https://github.com/docsifyjs/docsify/pull/1128
- https://snyk.io/vuln/SNYK-JS-DOCSIFY-567099
Get alerted when CVE-2020-7680 or the next vulnerability affects your stack