What’s Vulnerable › Vulnerabilities
CVE-2020-7690
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-06 · updated 2026-06-17
- Weakness: CWE-79
Description
All affected versions <2.0.0 of package jspdf are vulnerable to Cross-site Scripting (XSS). It is possible to inject JavaScript code via the html method.
Affected products
- parallax jsPDF: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: parallax jsPDF 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/MrRio/jsPDF/issues/2795
- https://snyk.io/vuln/SNYK-JS-JSPDF-575256
- https://github.com/MrRio/jsPDF/issues/2795
- https://snyk.io/vuln/SNYK-JS-JSPDF-575256
Get alerted when CVE-2020-7690 or the next vulnerability affects your stack