What’s Vulnerable › Vulnerabilities
CVE-2020-7698: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-29 · updated 2026-06-17
- Weakness: CWE-78
Description
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the project_configure endpoint, isn’t being sanitized.
Affected products
- Gerapy: from 0.0.0 before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: Gerapy 0.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/Gerapy/Gerapy/commit/e8446605eb2424717418eae199ec7aad573da2d2
- https://snyk.io/vuln/SNYK-PYTHON-GERAPY-572470
- https://github.com/Gerapy/Gerapy/commit/e8446605eb2424717418eae199ec7aad573da2d2
- https://snyk.io/vuln/SNYK-PYTHON-GERAPY-572470
Get alerted when CVE-2020-7698 or the next vulnerability affects your stack