What’s Vulnerable › Vulnerabilities
CVE-2020-7730: Command Injection
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-04 · updated 2026-06-17
- Weakness: CWE-78
Description
The package bestzip before 2.1.7 are vulnerable to Command Injection via the options param.
Affected products
- bestzip: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: bestzip 2.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/nfriedly/node-bestzip/commit/45d4a901478c6a8f396c8b959dd6cf8fd3f955b6
- https://snyk.io/vuln/SNYK-JS-BESTZIP-609371
- https://github.com/nfriedly/node-bestzip/commit/45d4a901478c6a8f396c8b959dd6cf8fd3f955b6
- https://snyk.io/vuln/SNYK-JS-BESTZIP-609371
Get alerted when CVE-2020-7730 or the next vulnerability affects your stack