What’s Vulnerable › Vulnerabilities
CVE-2020-7755: Regular Expression Denial of Service (ReDoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-10-27 · updated 2026-06-17
- Weakness: CWE-400
Description
All versions of package dat.gui are vulnerable to Regular Expression Denial of Service (ReDoS) via specifically crafted rgb and rgba values.
Affected products
- dat.gui: before 0.7.8 — fixed in 0.7.8
How to fix
Upgrade to a fixed version: dat.gui 0.7.8. Check the vendor advisory for mitigations.
References
- https://github.com/dataarts/dat.gui/issues/278
- https://snyk.io/vuln/SNYK-JS-DATGUI-1016275
- https://github.com/dataarts/dat.gui/issues/278
- https://snyk.io/vuln/SNYK-JS-DATGUI-1016275
Get alerted when CVE-2020-7755 or the next vulnerability affects your stack