What’s Vulnerable › Vulnerabilities
CVE-2020-7789: Command Injection
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-11 · updated 2026-06-17
- Weakness: CWE-78
Description
This affects the package node-notifier before 9.0.0. It allows an attacker to run arbitrary commands on Linux machines due to the options params not being sanitised when being passed an array.
Affected products
- node-notifier: before 8.0.1 — fixed in 8.0.1
- Npm Node-Notifier: before 8.0.1 — fixed in 8.0.1
How to fix
Upgrade to a fixed version: node-notifier 8.0.1; Npm Node-Notifier 8.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/mikaelbr/node-notifier/blob/master/lib/utils.js%23L303
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1050371
- https://snyk.io/vuln/SNYK-JS-NODENOTIFIER-1035794
- https://github.com/mikaelbr/node-notifier/blob/master/lib/utils.js%23L303
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1050371
- https://snyk.io/vuln/SNYK-JS-NODENOTIFIER-1035794
Get alerted when CVE-2020-7789 or the next vulnerability affects your stack