What’s Vulnerable › Vulnerabilities
CVE-2020-7795: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-02 · updated 2026-06-17
- Weakness: CWE-77
Description
The package get-npm-package-version before 1.0.7 are vulnerable to Command Injection via main function in index.js.
Affected products
- get-npm-package-version: before 1.0.7 — fixed in 1.0.7
How to fix
Upgrade to a fixed version: get-npm-package-version 1.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/hoperyy/get-npm-package-version/blob/338a5882298eb2c2194538db41166cae13c39e03/index.js%23L17
- https://github.com/hoperyy/get-npm-package-version/commit/40b1cf31a0607ea66f9e30a0c3af1383b52b2dec
- https://security.snyk.io/vuln/SNYK-JS-GETNPMPACKAGEVERSION-1050390
- https://www.npmjs.com/package/get-npm-package-version/v/1.0.6
- https://github.com/hoperyy/get-npm-package-version/blob/338a5882298eb2c2194538db41166cae13c39e03/index.js%23L17
- https://github.com/hoperyy/get-npm-package-version/commit/40b1cf31a0607ea66f9e30a0c3af1383b52b2dec
- https://security.snyk.io/vuln/SNYK-JS-GETNPMPACKAGEVERSION-1050390
- https://www.npmjs.com/package/get-npm-package-version/v/1.0.6
Get alerted when CVE-2020-7795 or the next vulnerability affects your stack