What’s Vulnerable › Vulnerabilities

CVE-2020-7919: Helm uses crypto package vulnerable to panic from malformed X.509 certificate

Description

Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients (resulting in a panic) via a malformed X.509 certificate.

Affected products

How to fix

Upgrade to a fixed version: Go 1.12.6, 1.13.7; Go Github.Com/Helm/Helm 2.16.8; Golang.Org/X/Crypto 0.0.0-20200124225646-8b5121be2f68; Go Helm.Sh/Helm/V3 3.1.0; Go Stdlib 1.12.16, 1.13.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-7919 or the next vulnerability affects your stack