What’s Vulnerable › Vulnerabilities
CVE-2020-7921: Administrative action may disable enforcement of per-user IP whitelisting
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-06 · updated 2026-06-17
- Weakness: CWE-182
Description
Improper serialization of internal state in the authorization subsystem in MongoDB Server's authorization subsystem permits a user with valid credentials to bypass IP whitelisting protection mechanisms following administrative action. This issue affects MongoDB Server v4.2 versions prior to 4.2.3; MongoDB Server v4.0 versions prior to 4.0.15; MongoDB Server v4.3 versions prior to 4.3.3and MongoDB Server v3.6 versions prior to 3.6.18.
Affected products
- MongoDB: from 3.6.0 before 3.6.18; from 4.0.0 before 4.0.15; from 4.2.0 before 4.2.3; from 4.3.0 before 4.3.3 — fixed in 3.6.18, 4.0.15, 4.2.3, 4.3.3
How to fix
Upgrade to a fixed version: MongoDB 3.6.18, 4.0.15, 4.2.3, 4.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-7921 or the next vulnerability affects your stack