What’s Vulnerable › Vulnerabilities
CVE-2020-7923: Specific GeoQuery can cause DoS against MongoDB Server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-21 · updated 2026-06-17
- Weakness: CWE-755
Description
A user authorized to perform database queries may cause denial of service by issuing specially crafted queries, which violate an invariant in the query subsystem's support for geoNear. This issue affects MongoDB Server v4.4 versions prior to 4.4.0-rc7; MongoDB Server v4.2 versions prior to 4.2.8 and MongoDB Server v4.0 versions prior to 4.0.19.
Affected products
- MongoDB: from 4.0 before 4.0.19; from 4.2 before 4.2.8; from 4.4 before 4.4.0 — fixed in 4.0.19, 4.2.8, 4.4.0
How to fix
Upgrade to a fixed version: MongoDB 4.0.19, 4.2.8, 4.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-7923 or the next vulnerability affects your stack