What’s Vulnerable › Vulnerabilities
CVE-2020-7925: Denial of Service when processing malformed Role names
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-475
Description
Incorrect validation of user input in the role name parser may lead to use of uninitialized memory allowing an unauthenticated attacker to use a specially crafted request to cause a denial of service. This issue affects MongoDB Server v4.4 versions prior to 4.4.0-rc12; MongoDB Server v4.2 versions prior to 4.2.9.
Affected products
- MongoDB: from 4.2.0 before 4.2.9; 4.4.0-rc1, 4.4.0-rc10, 4.4.0-rc11, 4.4.0-rc2, 4.4.0-rc3, 4.4.0-rc4 (+5) — fixed in 4.2.9
How to fix
Upgrade to a fixed version: MongoDB 4.2.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-7925 or the next vulnerability affects your stack