What’s Vulnerable › Vulnerabilities
CVE-2020-7926: Specific query can cause a DoS against MongoDB Server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-755
Description
A user authorized to perform database queries may cause denial of service by issuing a specially crafted query which violates an invariant in the server selection subsystem. This issue affects MongoDB Server v4.4 versions prior to 4.4.1. Versions before 4.4 are not affected.
Affected products
- MongoDB: from 4.4.0 before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: MongoDB 4.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-7926 or the next vulnerability affects your stack