What’s Vulnerable › Vulnerabilities

CVE-2020-7928: Improper neutralization of null byte leads to read overrun

Description

A user authorized to perform database queries may trigger a read overrun and access arbitrary memory by issuing specially crafted queries. This issue affects MongoDB Server v4.4 versions prior to 4.4.1; MongoDB Server v4.2 versions prior to 4.2.9; MongoDB Server v4.0 versions prior to 4.0.20 and MongoDB Server v3.6 versions prior to 3.6.20.

Affected products

How to fix

Upgrade to a fixed version: MongoDB 3.6.20, 4.0.20, 4.2.9, 4.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-7928 or the next vulnerability affects your stack