What’s Vulnerable › Vulnerabilities
CVE-2020-8028: salt-api is accessible to every user on SUSE Manager Server
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-17 · updated 2026-06-17
- Weakness: CWE-284
Description
A Improper Access Control vulnerability in the configuration of salt of SUSE Linux Enterprise Module for SUSE Manager Server 4.1, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Manager Server 3.2, SUSE Manager Server 4.0 allows local users to escalate to root on every system managed by SUSE manager. On the managing node itself code can be executed as user salt, potentially allowing for escalation to root there. This issue affects: SUSE Linux Enterprise Module for SUSE Manager Server 4.1 google-gson versions prior to 2.8.5-3.4.3, httpcomponents-client-4.5.6-3.4.2, httpcomponents-. SUSE Manager Proxy 4.0 release-notes-susemanager-proxy versions prior to 4.0.9-0.16.38.1. SUSE Manager Retail Branch Server 4.0 release-notes-susemanager-proxy versions prior to 4.0.9-0.16.38.1. SUSE Manager Server 3.2 salt-netapi-client versions prior to 0.16.0-4.14.1, spacewalk-. SUSE Manager Server 4.0 release-notes-susemanager versions prior to 4.0.9-3.54.1.
Affected products
- SUSE Salt-Netapi-Client: before 0.17.0-3.3.2; before 0.16.0-4.14.1; before 0.17.0-4.6.3 — fixed in 0.16.0-4.14.1, 0.17.0-3.3.2, 0.17.0-4.6.3
How to fix
Upgrade to a fixed version: SUSE Salt-Netapi-Client 0.16.0-4.14.1, 0.17.0-3.3.2, 0.17.0-4.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-8028 or the next vulnerability affects your stack