What’s Vulnerable › Vulnerabilities
CVE-2020-8114
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-05 · updated 2026-06-17
- Weakness: CWE-276
Description
GitLab EE 8.9 and later through 12.7.2 has Insecure Permission
Affected products
- GitLab: from 8.9.0 before 12.5.9; from 12.6.0 before 12.6.6; from 12.7.0 through 12.7.2 — fixed in 12.5.9, 12.6.6
How to fix
Upgrade to a fixed version: GitLab 12.5.9, 12.6.6. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2020/01/30/security-release-gitlab-12-7-4-released/
- https://about.gitlab.com/releases/categories/releases/
- https://gitlab.com/gitlab-org/gitlab/issues/37468
- https://about.gitlab.com/releases/2020/01/30/security-release-gitlab-12-7-4-released/
- https://about.gitlab.com/releases/categories/releases/
- https://gitlab.com/gitlab-org/gitlab/issues/37468
Get alerted when CVE-2020-8114 or the next vulnerability affects your stack