What’s Vulnerable › Vulnerabilities
CVE-2020-8126
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-07 · updated 2026-06-17
- Weakness: CWE-78
Description
A privilege escalation in the EdgeSwitch prior to version 1.7.1, an CGI script don't fully sanitize the user input resulting in local commands execution, allowing an operator user (Privilege-1) to escalate privileges and became administrator (Privilege-15).
Affected products
- EdgeSwitch: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: EdgeSwitch 1.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-8126 or the next vulnerability affects your stack