What’s Vulnerable › Vulnerabilities
CVE-2020-8149
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-15 · updated 2026-06-17
- Weakness: CWE-94
Description
Lack of output sanitization allowed an attack to execute arbitrary shell commands via the logkitty npm package before version 0.7.1.
Affected products
- logkitty: before 0.7.1 — fixed in 0.7.1
How to fix
Upgrade to a fixed version: logkitty 0.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-8149 or the next vulnerability affects your stack