What’s Vulnerable › Vulnerabilities
CVE-2020-8155
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An outdated 3rd party library in the Files PDF viewer for Nextcloud Server 18.0.2 caused a Cross-site scripting vulnerability when opening a malicious PDF.
Affected products
- Nextcloud Server: before 18.0.3 — fixed in 18.0.3
How to fix
Upgrade to a fixed version: Nextcloud Server 18.0.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00038.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KC6HLX5SG4PZO6Y54D2LFJ4ATG76BKOP/
- https://nextcloud.com/security/advisory/?id=NC-SA-2020-019
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00038.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KC6HLX5SG4PZO6Y54D2LFJ4ATG76BKOP/
- https://nextcloud.com/security/advisory/?id=NC-SA-2020-019
Get alerted when CVE-2020-8155 or the next vulnerability affects your stack