What’s Vulnerable › Vulnerabilities
CVE-2020-8163
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 82.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-02 · updated 2026-06-17
- Weakness: CWE-94
Description
The is a code injection vulnerability in versions of Rails prior to 5.0.1 that wouldallow an attacker who controlled the `locals` argument of a `render` call to perform a RCE.
Affected products
- Debian Linux: 9.0
- Ruby on Rails: before 5.0.1 — fixed in 5.0.1
How to fix
Upgrade to a fixed version: Ruby on Rails 5.0.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/158604/Ruby-On-Rails-5.0.1-Remote-Code-Execution.html
- https://groups.google.com/g/rubyonrails-security/c/hWuKcHyoKh0
- https://hackerone.com/reports/304805
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html
- http://packetstormsecurity.com/files/158604/Ruby-On-Rails-5.0.1-Remote-Code-Execution.html
- https://groups.google.com/g/rubyonrails-security/c/hWuKcHyoKh0
- https://hackerone.com/reports/304805
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html
Get alerted when CVE-2020-8163 or the next vulnerability affects your stack