What’s Vulnerable › Vulnerabilities
CVE-2020-8164: Possible Strong Parameters Bypass in ActionPack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-502
Description
A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1, 15.2
- Ruby on Rails: before 5.2.4.3; from 6.0.0 before 6.0.3.1 — fixed in 5.2.4.3, 6.0.3.1
- Rubygems Actionpack: from 5.0.0 before 5.2.4.3; from 6.0.0 before 6.0.3.1; 5.0.0, 5.0.0.1, 5.0.1, 5.0.1.rc1, 5.0.1.rc2, 5.0.2 (+59) — fixed in 5.2.4.3, 6.0.3.1
How to fix
Upgrade to a fixed version: Ruby on Rails 5.2.4.3, 6.0.3.1; Rubygems Actionpack 5.2.4.3, 6.0.3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00089.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00093.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00107.html
- https://groups.google.com/g/rubyonrails-security/c/f6ioe4sdpbY
- https://hackerone.com/reports/292797
- https://lists.debian.org/debian-lts-announce/2020/06/msg00022.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html
- https://www.debian.org/security/2020/dsa-4766
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00089.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00093.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00107.html
- https://groups.google.com/g/rubyonrails-security/c/f6ioe4sdpbY
Get alerted when CVE-2020-8164 or the next vulnerability affects your stack