What’s Vulnerable › Vulnerabilities
CVE-2020-8165: ActiveSupport potentially unintended unmarshalling of user-provided objects in MemCacheStore and RedisCacheStore
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 45.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-502
Description
A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an attacker to unmarshal user-provided objects in MemCacheStore and RedisCacheStore potentially resulting in an RCE.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- openSUSE Leap: 15.1, 15.2
- Ruby on Rails: before 5.2.4.3; from 6.0.0 before 6.0.3.1 — fixed in 5.2.4.3, 6.0.3.1
- Rubygems Activesupport: from 5.0.0 before 5.2.4.3; from 6.0.0 before 6.0.3.1; 5.0.0, 5.0.0.1, 5.0.1, 5.0.1.rc1, 5.0.1.rc2, 5.0.2 (+59) — fixed in 5.2.4.3, 6.0.3.1
How to fix
Upgrade to a fixed version: Ruby on Rails 5.2.4.3, 6.0.3.1; Rubygems Activesupport 5.2.4.3, 6.0.3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00034.html
- https://groups.google.com/g/rubyonrails-security/c/bv6fW4S0Y1c
- https://hackerone.com/reports/413388
- https://lists.debian.org/debian-lts-announce/2020/06/msg00022.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00013.html
- https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released/
- https://www.debian.org/security/2020/dsa-4766
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00031.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00034.html
- https://groups.google.com/g/rubyonrails-security/c/bv6fW4S0Y1c
- https://hackerone.com/reports/413388
Get alerted when CVE-2020-8165 or the next vulnerability affects your stack