What’s Vulnerable › Vulnerabilities
CVE-2020-8172
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-08 · updated 2026-06-17
- Weakness: CWE-295
Description
TLS session reuse can lead to host certificate verification bypass in node version < 12.18.0 and < 14.4.0.
Affected products
- Node.js: from 12.0.0 before 12.18.0; from 14.0.0 before 14.4.0 — fixed in 12.18.0, 14.4.0
- Oracle Banking Extensibility Workbench: 14.3.0, 14.4.0
- Oracle Blockchain Platform: before 21.1.2 — fixed in 21.1.2
- Oracle Corporation GraalVM Enterprise Edition: 19.3.2, 20.1.0
- Oracle Corporation MySQL Cluster: through 7.3.30; from 7.4.0 through 7.4.29; from 7.5.0 through 7.5.19; from 7.6.0 through 7.6.15; from 8.0.0 through 8.0.21
How to fix
Upgrade to a fixed version: Node.js 12.18.0, 14.4.0; Oracle Blockchain Platform 21.1.2. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/811502
- https://nodejs.org/en/blog/vulnerability/june-2020-security-releases/
- https://security.gentoo.org/glsa/202101-07
- https://security.netapp.com/advisory/ntap-20200625-0002/
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://hackerone.com/reports/811502
- https://nodejs.org/en/blog/vulnerability/june-2020-security-releases/
- https://security.gentoo.org/glsa/202101-07
Get alerted when CVE-2020-8172 or the next vulnerability affects your stack