What’s Vulnerable › Vulnerabilities
CVE-2020-8185
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-02 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service vulnerability exists in Rails <6.0.3.2 that allowed an untrusted user to run any pending migrations on a Rails app running in production.
Affected products
- Fedoraproject Fedora: 33
- Ruby on Rails: from 6.0.0 before 6.0.3.2 — fixed in 6.0.3.2
How to fix
Upgrade to a fixed version: Ruby on Rails 6.0.3.2. Check the vendor advisory for mitigations.
References
- https://groups.google.com/g/rubyonrails-security/c/pAe9EV8gbM0
- https://hackerone.com/reports/899069
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XJ7NUWXAEVRQCROIIBV4C6WXO6IR3KSB/
- https://groups.google.com/g/rubyonrails-security/c/pAe9EV8gbM0
- https://hackerone.com/reports/899069
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XJ7NUWXAEVRQCROIIBV4C6WXO6IR3KSB/
Get alerted when CVE-2020-8185 or the next vulnerability affects your stack