What’s Vulnerable › Vulnerabilities
CVE-2020-8187
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-10 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper input validation in Citrix ADC and Citrix Gateway versions before 11.1-63.9 and 12.0-62.10 allows unauthenticated users to perform a denial of service attack.
Affected products
- Citrix Application Delivery Controller Firmware: from 11.1 before 11.1-63.9; from 12.0 before 12.0-62.10 — fixed in 11.1-63.9, 12.0-62.10
- Citrix Netscaler Gateway Firmware: from 11.1 before 11.1-63.9; from 12.0 before 12.0-62.10 — fixed in 11.1-63.9, 12.0-62.10
- Citrix ADC, Citrix Gateway: 11.1-63.9, 12.0-62.10
How to fix
Upgrade to a fixed version: Citrix Application Delivery Controller Firmware 11.1-63.9, 12.0-62.10; Citrix Netscaler Gateway Firmware 11.1-63.9, 12.0-62.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-8187 or the next vulnerability affects your stack