What’s Vulnerable › Vulnerabilities
CVE-2020-8201
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-18 · updated 2026-06-17
- Weakness: CWE-444
Description
Node.js < 12.18.4 and < 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture of the underlying system. The attack was possible due to a bug in processing of carrier-return symbols in the HTTP header names.
Affected products
- Fedoraproject Fedora: 33
- Node.js: from 12.0.0 before 12.18.4; from 14.0.0 before 14.11.0 — fixed in 12.18.4, 14.11.0
- openSUSE Leap: 15.2
How to fix
Upgrade to a fixed version: Node.js 12.18.4, 14.11.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00011.html
- https://hackerone.com/reports/922597
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4OOYAMJVLLCLXDTHW3V5UXNULZBBK4O6/
- https://nodejs.org/en/blog/vulnerability/september-2020-security-releases/
- https://security.gentoo.org/glsa/202101-07
- https://security.netapp.com/advisory/ntap-20201009-0004/
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00011.html
- https://hackerone.com/reports/922597
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4OOYAMJVLLCLXDTHW3V5UXNULZBBK4O6/
- https://nodejs.org/en/blog/vulnerability/september-2020-security-releases/
- https://security.gentoo.org/glsa/202101-07
- https://security.netapp.com/advisory/ntap-20201009-0004/
Get alerted when CVE-2020-8201 or the next vulnerability affects your stack