What’s Vulnerable › Vulnerabilities
CVE-2020-8233
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-17 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability exists in EdgeSwitch firmware <v1.9.0 that allowed an authenticated read-only user to execute arbitrary shell commands over the HTTP interface, allowing them to escalate privileges.
Affected products
- openSUSE Backports Sle: 15.0-sp1, 15.0-sp2
- openSUSE Leap: 15.1, 15.2
- Ui Edgeswitch Firmware: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Ui Edgeswitch Firmware 1.9.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00019.html
- https://community.ui.com/releases/EdgeMAX-EdgeSwitch-Firmware-v1-9-1-v1-9-1/8a87dfc5-70f5-4055-8d67-570db1f5695c
- https://community.ui.com/releases/Security-advisory-bulletin-014-014/1c32c056-2c64-4e60-ac23-ce7d8f387821
- https://www.ui.com/download/edgemax
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00019.html
- https://community.ui.com/releases/EdgeMAX-EdgeSwitch-Firmware-v1-9-1-v1-9-1/8a87dfc5-70f5-4055-8d67-570db1f5695c
- https://community.ui.com/releases/Security-advisory-bulletin-014-014/1c32c056-2c64-4e60-ac23-ce7d8f387821
- https://www.ui.com/download/edgemax
Get alerted when CVE-2020-8233 or the next vulnerability affects your stack