What’s Vulnerable › Vulnerabilities

CVE-2020-8244: Remote Memory Exposure in bl

Description

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Affected products

How to fix

Upgrade to a fixed version: Bufferlist Project Bufferlist 1.2.3, 2.2.1, 3.0.1, 4.0.3; Npm Bl 1.2.3, 2.2.1, 3.0.1, 4.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-8244 or the next vulnerability affects your stack