What’s Vulnerable › Vulnerabilities
CVE-2020-8300
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-16 · updated 2026-06-17
- Weakness: CWE-284
Description
Citrix ADC and Citrix/NetScaler Gateway before 13.0-82.41, 12.1-62.23, 11.1-65.20 and Citrix ADC 12.1-FIPS before 12.1-55.238 suffer from improper access control allowing SAML authentication hijack through a phishing attack to steal a valid user session. Note that Citrix ADC or Citrix Gateway must be configured as a SAML SP or a SAML IdP for this to be possible.
Affected products
- Citrix Application Delivery Controller Firmware: from 11.1 before 11.1-65.20; from 12.1 before 12.1-62.23; from 13.0 before 13.0-82.41; from 12.1 before 12.1-55.238 — fixed in 11.1-65.20, 12.1-62.23, 13.0-82.41, 12.1-55.238
- NetScaler Gateway: from 12.1 before 12.1-62.23; from 13.0 before 13.0-82.41 — fixed in 12.1-62.23, 13.0-82.41
- Citrix NetScaler Gateway: from 11.1 before 11.1-65.20 — fixed in 11.1-65.20
- Citrix ADC, Citrix Gateway: Fixed in Citrix ADC and Citrix Gateway 13.0 before 13.0-82.41, Citrix ADC and Citrix Gateway 12.1 before 12.1-62.23, Citrix ADC and NetScaler Gateway 11.1 before 11.1-65.20, Citrix ADC 12.1-FIPS before 12.1-55.238
How to fix
Upgrade to a fixed version: Citrix Application Delivery Controller Firmware 11.1-65.20, 12.1-62.23, 13.0-82.41, 12.1-55.238; NetScaler Gateway 12.1-62.23, 13.0-82.41; Citrix NetScaler Gateway 11.1-65.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-8300 or the next vulnerability affects your stack