What’s Vulnerable › Vulnerabilities
CVE-2020-8417
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The Code Snippets plugin before 2.14.0 for WordPress allows CSRF because of the lack of a Referer check on the import menu.
Affected products
- Code Snippets: before 2.14.0 — fixed in 2.14.0
How to fix
Upgrade to a fixed version: Code Snippets 2.14.0. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/code-snippets/#developers
- https://wpvulndb.com/vulnerabilities/10050
- https://wordpress.org/plugins/code-snippets/#developers
- https://wpvulndb.com/vulnerabilities/10050
Get alerted when CVE-2020-8417 or the next vulnerability affects your stack