What’s Vulnerable › Vulnerabilities
CVE-2020-8498
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS exists in the shortcode functionality of the GistPress plugin before 3.0.2 for WordPress via the includes/class-gistpress.php id parameter. This allows an attacker with the WordPress Contributor role to execute arbitrary JavaScript code with the privileges of other users (e.g., ones who have the publish_posts capability).
Affected products
- Gistpress Project Gistpress: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: Gistpress Project Gistpress 3.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/bradyvercher/gistpress/commit/e3f260edb6673227b0471c74b7ab13c094411ef7
- https://github.com/bradyvercher/gistpress/releases/tag/v3.0.2
- https://wpvulndb.com/vulnerabilities/10053
- https://github.com/bradyvercher/gistpress/commit/e3f260edb6673227b0471c74b7ab13c094411ef7
- https://github.com/bradyvercher/gistpress/releases/tag/v3.0.2
- https://wpvulndb.com/vulnerabilities/10053
Get alerted when CVE-2020-8498 or the next vulnerability affects your stack