What’s Vulnerable › Vulnerabilities
CVE-2020-8517
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-04 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in Squid before 4.10. Due to incorrect input validation, the NTLM authentication credentials parser in ext_lm_group_acl may write to memory outside the credentials buffer. On systems with memory access protections, this can result in the helper process being terminated unexpectedly. This leads to the Squid process also terminating and a denial of service for all clients using the proxy.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- openSUSE Leap: 15.1
- Squid: before 4.10 — fixed in 4.10
How to fix
Upgrade to a fixed version: Squid 4.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00018.html
- http://www.squid-cache.org/Advisories/SQUID-2020_3.txt
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-6982f1187a26557e582172965e266f544ea562a5.patch
- https://security.gentoo.org/glsa/202003-34
- https://security.netapp.com/advisory/ntap-20210304-0002/
- https://usn.ubuntu.com/4289-1/
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00018.html
- http://www.squid-cache.org/Advisories/SQUID-2020_3.txt
Get alerted when CVE-2020-8517 or the next vulnerability affects your stack