What’s Vulnerable › Vulnerabilities
CVE-2020-8776
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Alfresco Enterprise before 5.2.7 and Alfresco Community before 6.2.0 (rb65251d6-b368) has XSS via the URL property of a file.
Affected products
- Alfresco: before 5.2.7; before 6.2.0 — fixed in 5.2.7, 6.2.0
How to fix
Upgrade to a fixed version: Alfresco 5.2.7, 6.2.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/156599/Alfresco-5.2.4-Cross-Site-Scripting.html
- https://gitlab.com/snippets/1937042
- https://issues.alfresco.com/jira/browse/ALF-22110
- http://packetstormsecurity.com/files/156599/Alfresco-5.2.4-Cross-Site-Scripting.html
- https://gitlab.com/snippets/1937042
- https://issues.alfresco.com/jira/browse/ALF-22110
Get alerted when CVE-2020-8776 or the next vulnerability affects your stack